Mavenでコンパイル時のJavaのバージョンを設定する

Maven でコンパイル時に指定されるJavaのバージョンを変更するには、 pom.xml ファイルの <project></project> ルールの直下に以下のルールを指定します。

未だにデフォルト値が1.5になっているため、 これを指定しないとJava6からの機能であるアノテーションなどすら利用できません。

<properties>
  <maven.compiler.source>1.7</maven.compiler.source>
  <maven.compiler.target>1.7</maven.compiler.target>
</properties>
最終更新: 5/10/2015